[Fix phpMyAdmin] Konfigurace file nyní potřebuje tajnou přístupovou frázi (blowfish_secret)

Ať už je nainstalován phpMyAdmin Server ubuntu, CentOS nebo atd. Fedora distribuce, zpráva "Konfigurace file nyní potřebuje tajnou přístupovou frázi (blowfish_secret)"S červenou v dolní části indexu to dává bolesti hlavy. Zvláště při správné konfiguraci v části "/etc/phpMyAdmin/config.inc.php".
Samozřejmě, cesta se může lišit od jedné konfigurace k druhé, ale dál CentOS 7 cu phpMyAdmin nainstalován pomocí "yum"In"remi.repo„Konfigurační soubor se bude nacházet v“ / etc / phpMyAdmin /“.

Dobře, podívejme se, jak řešíme "Konfigurace file nyní potřebuje tajnou přístupovou frázi (blowfish_secret)"Pokud je config.inc.php máme tento řádek:

$cfg['blowfish_secret'] = 'gNsWq$%#%$#%EDFSsffsegbVp6LCJw6w'; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */

Pokud tento řádek a máme „klíč“ nad 32 znaků v phpMyAdmin červeném zprávě by se měla vyčistit.
V případě, toto nestalo, měli byste vymazat cookies z prohlížeče a odhlásit phpMyAdmin. Při příštím přihlášení se zobrazí zpráva "Konfigurace file nyní potřebuje tajnou přístupovou frázi (blowfish_secret)„To nebude přítomna.
Ačkoli existují situace, ve kterých je přítomen ne z důvodu chyby konfigurace soubor config.inc.php, ale protože oprávnění složky, když byl.

Spustit v terminálu příkazového řádku:

 chown -R root:<user web> /etc/phpMyAdmin/

Všechno by mělo být v pořádku. Pokud používáte Apache namísto "uživatelského webu", nastavte "httpd", "nginx" nebo jak máte uživatele webového procesu na serveru.

Tyto tipy jsem napsal, protože jsem procházel všechny konfigurace phpMyAdmin déle než 2 hodiny a stále se nemůžu zbavit zprávy: Konfigurace file nyní potřebuje tajnou přístupovou frázi (blowfish_secret). Poté, co jsem vyřešil oprávnění / skupiny, zmizel.

[Fix phpMyAdmin] Konfigurace file nyní potřebuje tajnou přístupovou frázi (blowfish_secret)

O autorovi

Stealth LP

Zakladatel a editor Tajnost SettingsDatum 2006.
Zkušenosti s operačními systémy Linux (zejména CentOS), Mac OS X, Windows XP> Windows 10 a WordPress (CMS).

3 Komentáře

Zanechat komentář