Opraven problém: Váš server běží PHP verze 5.1.6 Ale 3.2.1 vyžaduje alespoň 5.2.4 WordPress.

Upozornění pro všechny není dobře známo, že pro instalovat nebo se upgradovat'S novější verze 3.2Je nutné, aby musí být nainstalována novější verze 5.2.4.

Pokud je server nainstalovat verzi PHP starší než 5.2.4 nainstalovat verzi WordPress 3.2.1Objeví se chyba / Zpráva "Váš server běží PHP verze 5.1.6 Vyžaduje WordPress 3.2.1 ale alespoň 5.2.4".
Problém lze vyřešit velmi jednoduše upgrade PHP, ale před tím by měla pár věcí v úvahu. První, upgrade PHP je možné na sdílený hosting. Takže si můžete udělat upgrade, musíte mít přístup správce k serveru (Dedikovaný server nebo VPS). Ve druhé, by měl před upgradem na dokumentovat a být si vědom, že Nová verze PHP není uveden Chyby jiné stránky hostované na tomto serveru.

Pro je nejrozšířenější operační systém pro Webové servery (Agreart a / WHM) Ukázat vám, jak to udělat Upgrade na PHP na CentOS 5.2.10.x 5 32-bit.

Aktualizujte PHP na CentOS 5.1.x 5.2.x na 5.x 32-bit

1. Zkontrolujte, které balíčky / moduly jsou nainstalovány PHP (např. php-mcrypt) spolu se standardním paketem. Pokud existuje, by měl být zrušen, nebo actuzlizate.

Kontrola nainstalovaných balíčků:

rpm-qa | grep php

old_php_version

2. Přidat úložišť Nutný upgradovat'S PHP verze.

nano / etc / yum.repos.d / CentOS-Testing.repo

Nový soubor (CentOS-Testing.repo) Bude přidejte následující kód (copy / paste):

[C5-testovací]
name = CentOS-Testování 5
baseUrl = http://dev.centos.org/centos/ $ releasever / zkoušení / $ basearch /
enabled = 1
gpgcheck = 1
gpgkey = http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs = php *

Ctrl + X k uložení souboru CentOS-Testing.repo.

3. Aktualizace PHP přes yum:

yum aktualizace

4. Restart / httpd :

service httpd restart

Po restartu httpd a zkontrolovat verzi nainstalovaných balíčků:

new_php_version

Zkontrolujte, zda nejsou chyby v modulech / balení:

php-v

PHP Upgrade / CentOS 32-bit (i386).

Opraven problém: Váš server běží PHP verze 5.1.6 Ale 3.2.1 vyžaduje alespoň 5.2.4 WordPress.

O autorovi

Stealth LP

Zakladatel a editor Stealth nastaveníDatum 2006.
Zkušenosti v operačních systémech Linux (zejména CentOS), Mac OS X, Windows XP> Windows 10 a WordPress (CMS).

Zanechat komentář

Tyto stránky používají Akismet k omezení spamu. Zjistěte, jak jsou vaše údaje komentářů zpracovávány.