Opravit Error: Vaše PHP installZdá se, že chybí rozšíření MySQL, které vyžaduje WordPress

"Vaše PHP installZdá se, že chybí rozšíření MySQL, které vyžaduje WordPress„Je chyba, se kterou se setkalo mnoho vlastníků blogů a webových stránek WordPress.
To není důvod k obavám. Nedostatek rozšíření MySQL z PHP je typické operační systémy instalované od nuly, VPS nebo dedikovaných serverů, kde rozšíření PHP nebyla součástí instalačního balíčku. Tento problém je přítomen na obou ubuntu a CentOS. V tomto scénáři je problém vyřešen velmi jednoduše pomocí a update PHP a instalace modulů"php-mysql".
Update Instalace rozšíření PHP a MySQL na Ubuntu

apt-get update
apt-get install php-mysql

Update Instalace rozšíření PHP a MySQL na CentOS

yum update
yum install php70w-mysql

Po tomto kroku restartmáte službu Apache nebo Nginx.

Také jsem narazil na scénář, ve kterém ačkoli rozšíření MySQL v PHP existuje, blog byl vytvořen na WordPress zobrazila chyba „Vaše PHP installZdá se, že chybí rozšíření MySQL, které vyžaduje WordPress“. K chybě většinou dojde během instalace WordPress. Tentokrát se však objevil na již několik let aktivním blogu.
V této situaci jsem zjistil, že problém není s moduly PHP, ale s velmi starou verzí WordPress, který již není kompatibilní s PHP 7.4.4RC1. Jednoduchý upgrade WordPress nejnovější verze chybu opravila.

Vášnivý k technologii, rád testuji a píšu výukové programy o operačních systémech macOS, Linux, Windows, o WordPress, WooCommerce a konfiguraci webových serverů LEMP (Linux, NGINX, MySQL a PHP). píšu dál StealthSettings.com od roku 2006 ao několik let později jsem začal psát na iHowTo.Tips výukové programy a novinky o zařízeních v ekosystému Apple: iPhoneiPad Apple Hodinky, HomePod, iMac, MacBook, AirPods a příslušenství.

Zanechat komentář